.NET 6

The QLM Management Console now uses .NET6 – Windows

QlmLicenseLib.dll is now available for .NET6

The QlmLicenseWizard.exe is now available for .NET 6 – Windows only

QLM Management Console

Tooltip over the Activation Key in the Manage Keys tab now displays Analytics information such as the real Last Accessed Date

You can now create email notifications based on changes to the Customers table such as when a new customer is created.

Setting the SMTP Server on the client side now automatically updates the server’s settings.

Schedule Tasks

You can now force the Start Time of a scheduled task to always run at a specified time.

Performance and memory footprint improvement when sending automated emails.

Added support for binding a license to a Docker Container. For more information, click here.

Docker Container

QLM License Wizard

User Registration Page – New Properties

QlmTrialKeyUserGroup allows you to set the Affiliate ID when generating a trial key from the QLM License Wizard.

QlmTrialKeyArgs allows you to set any argument when generating a trial key from the QLM License Wizard.

QlmTrialKeyUserData allows you to set the User Data when generating a trial key from the QLM License Wizard.

Library and API

All QLM DLLs are now digitally signed.

Added strong name validation of QlmLicenseLib.dll to the LicenseValidator class to prevent hacking DLL for non .NET applications that dynamically load the DLL. You must generate a new LicenseValidator class to take advantage of this feature.

Added support for QlmUniqueSystemIdentifier2.

New API GetUniqueCombinedSystemIdentifier that combines system identifiers.

License Server

Added 2 server properties to configure the trial registration form title and caption.

QLM Self Help now displays the detailed license information including the number of remaining deactivations and Analytics Last Accessed Date.

Block Computer ID.

New Requirements

The QLM License Server now requires .NET 4.62

The QLM Customer Portal now requires .NET 4.72

Important Notes

EXE Protection will no longer be maintained.

QLM Engine Version 4.0 and lower are no longer supported.